DRAKON.SU
https://forum.drakon.su/

Тестирование ИС Дракон
https://forum.drakon.su/viewtopic.php?f=144&t=2689
Страница 13 из 14

Автор:  adva [ Понедельник, 10 Декабрь, 2012 08:45 ]
Заголовок сообщения:  Re: Тестирование ИС Дракон

Еще одна не понятная особенность иконы полка: не всегда с первого раза получается выбрать нижнюю часть для редактирования текста (закономерности не выявил)

Автор:  adva [ Понедельник, 10 Декабрь, 2012 09:31 ]
Заголовок сообщения:  Re: Тестирование ИС Дракон

хотя закономерность выявил, если примерно ниже середины полки щелкнуть, то выделяется нижняя часть, если выше - то верхняя

Автор:  ==== [ Понедельник, 10 Декабрь, 2012 20:46 ]
Заголовок сообщения:  Re: Тестирование ИС Дракон

adva писал(а):
Не понял, возможности перемещения икон не осталось? А то в схеме гном, часто мнемонический блок смещается правее чем нужно (если несколько блоков друг под другом), а это не очень нравится
Да, иконы относительно шампура и сами шампуры теперь не перемещаются.
В блоке Запоминатель: меняем ширину для правой иконы - МнемоническийБлок, тем самым устанавливаем ширину всего блока Запоминатель; меняем ширину левой иконы - Указатель, тем самым устанавливаем границу между иконами не меняя ширины всего блока Запоминатель.

adva писал(а):
Еще одна не понятная особенность иконы полка: не всегда с первого раза получается выбрать нижнюю часть для редактирования текста (закономерности не выявил)
adva писал(а):
хотя закономерность выявил, если примерно ниже середины полки щелкнуть, то выделяется нижняя часть, если выше - то верхняя
Для икон с двумя частями части выбираются раздельно, у выбранной части меняется цвет фона и в строке состояний соответственно выводится выбор "Текст верхний" или "Текст нижний". Части в иконе разделены границей.

Автор:  adva [ Вторник, 11 Декабрь, 2012 06:18 ]
Заголовок сообщения:  Re: Тестирование ИС Дракон

Геннадий Тышов писал(а):
1) В блоке Запоминатель: меняем ширину для правой иконы - МнемоническийБлок, тем самым устанавливаем ширину всего блока Запоминатель; меняем ширину левой иконы - Указатель, тем самым устанавливаем границу между иконами не меняя ширины всего блока Запоминатель.

я говорил о эффекте, который привожу в скриншоте

Геннадий Тышов писал(а):
2) Для икон с двумя частями части выбираются раздельно, у выбранной части меняется цвет фона и в строке состояний соответственно выводится выбор "Текст верхний" или "Текст нижний". Части в иконе разделены границей.

Я в курсе, что части выбираются раздельно, но при щелчке мыши в верхней половине нижней части, выбирается верхняя часть, что очень странно (примерную позицию щелчка мышки привел на скриншоте). В принципе если знать эту особенность, то работать можно, но пока не выяснил это, очень долго приходилось щелкать по нижней части, чтобы текст отредактировать

Вложения:
эффекты_.png
эффекты_.png [ 56.68 КБ | Просмотров: 21563 ]

Автор:  ==== [ Вторник, 11 Декабрь, 2012 17:11 ]
Заголовок сообщения:  Re: Тестирование ИС Дракон

adva, визуальные картинки понял, спасибо за замечания.
Доработаем.

Сделано
Выпуск от 11.12.2012 - заменен
Выполнено 32 скачивания.

Автор:  adva [ Среда, 12 Декабрь, 2012 03:58 ]
Заголовок сообщения:  Re: Тестирование ИС Дракон

Геннадий Тышов писал(а):
Сделано

Спасибо, полка работает, гном тоже воспроизвести не удалось

Автор:  adva [ Четверг, 13 Декабрь, 2012 08:56 ]
Заголовок сообщения:  Re: Тестирование ИС Дракон

Предыдущие версии сохраняли в графич. файл. Сейчас почему-то не получается это сделать. После того как открываю схему и первый раз захожу в меню файл, выскакивает сообщение "Установка не выполнена". Нажимаю "Ок", опять захожу в Файл-Сохранить как (для граф.). Ничего не происходит. Файл не создается

Автор:  ==== [ Четверг, 13 Декабрь, 2012 18:09 ]
Заголовок сообщения:  Re: Тестирование ИС Дракон

adva, смотрите здесь пояснение к выпуску от 19.11.2012 и здесь, можно обратиться письмом к автору.

Автор:  adva [ Пятница, 14 Декабрь, 2012 05:31 ]
Заголовок сообщения:  Re: Тестирование ИС Дракон

А сам текст лицензии, где почитать можно?

Автор:  ==== [ Пятница, 14 Декабрь, 2012 05:37 ]
Заголовок сообщения:  Re: Тестирование ИС Дракон

Документа лицензии нет, а предусмотрена процедура установки программы на компьютер(ы), т.е. привязка программы к железу и/или флэшке. Установка выполняется при обращении к автору.

Наличие флешки позволяет использовать программу на любом компьютере: дома, на работе, на компьютере с прошедшим сроком ознакомления.

Автор:  Евгений Дудка [ Пятница, 14 Декабрь, 2012 13:50 ]
Заголовок сообщения:  Re: Тестирование ИС Дракон

Здравствуйте.
При работе выявлена интересная особенность. Если добавляю к нужному мне блоку Левый комментарий, то схема перестраивается странным способом. Зато с правым комментарием всё отлично получается. Я плохо знаю Дракон - может, левый комментарий не всегда и можно использовать?
На тот случай, если автор программы заинтересуется, прикладываю скриншоты этого "фокуса". И сам исходный файл, если это поможет.
Описание: создавал в версии Дракона от 2012_11_19. После этой аномалии обновился до Dragon_2012_12_11. Но это ничего не изменило.

Вложения:
Комментарий к файлу: сам файл схемы
algoritm_win.drt [1.34 КБ]
Скачиваний: 566
Комментарий к файлу: картинка после
step2.png
step2.png [ 22.18 КБ | Просмотров: 21398 ]
Комментарий к файлу: картинка до...
step1.png
step1.png [ 26.53 КБ | Просмотров: 21398 ]

Автор:  Евгений Дудка [ Пятница, 14 Декабрь, 2012 16:22 ]
Заголовок сообщения:  Re: Тестирование ИС Дракон

По поводу предыдущего моего сообщения - там мной было криво реализовано цикл ПОКА. После исправления этой "кривизны" схема упростилась, правый и левый комментарий ставятся одинаково хорошо и правильно.

Автор:  ==== [ Пятница, 14 Декабрь, 2012 17:19 ]
Заголовок сообщения:  Re: Тестирование ИС Дракон

Евгений Дудка, спасибо за замечание.

Скачал файл.
Да, действительно левый комментарий странно присоединяется.
Разберемся и доработаем.


В некоторых случаях в Примитиве при присоединении Левого комментария или Синхронизатора происходит перемещение иконы вверх выше заголовка. Дефект схемы устранялся при выполнении для схемы обновления.

Сделано. Выпуск ИС Дракон от 14.12.2012
Вложение:
Dragon_2012_12_14.rar

Автор:  ==== [ Пятница, 14 Декабрь, 2012 19:32 ]
Заголовок сообщения:  Re: Тестирование ИС Дракон

Выпуск ИС Дракон от 14.12.2012 здесь
Перечень выпусков здесь

Прошу сообщать Ваши отзывы, замечания и предложения.

Автор:  SergeyNK [ Вторник, 15 Январь, 2013 18:36 ]
Заголовок сообщения:  Re: Тестирование ИС Дракон

Уважаемый Геннадий Николаевич!

Хочу оформить алгоритм обработки одного из протокольных запросов с вызовами множества мелких функций (в основном, схема "примитив" и числом более полста), которые расположены в соседнем программном модуле. Вот этот модуль вытягивается в ширину неимоверно.
Можно ли как-то располагать схемы на одном листе в несколько рядов? Имеются ли способы рационального расположения схем на листе? Подскажите, как быть в данном случае.

Спасибо.

Автор:  ==== [ Вторник, 15 Январь, 2013 19:55 ]
Заголовок сообщения:  Re: Тестирование ИС Дракон

SergeyNK,
размещение схем на листе производиться только линейно вдоль верхней стороны листа.
Ранее пытался предоставить пользователю возможность самому размещать схемы, но оказалось очень неудобно и хлопотно их позиционировать вручную в 2-х измерениях листа.

У Вас в модуле много схем, разместите их на нескольких листах, возможность переноса схемы с листа на лист есть, используется графический буфер программы.
Икона Модуль должна находиться на одном из листов в схеме Гном и должна содержать список ссылок на все схемы всех листов модуля. Рекомендуется, последовательность размещения схем в списке иконы Модуль и на листах устанавливать ту же, что и требуется в генерируемом промежуточном коде.

К сведению -
В очередном выпуске ИС Дракон в схеме Гном предусмотрено отображение вызовов процедур обработчиков событий интерфейсных элементов. Сейчас схемы-процедуры обработчиков событий присутствую в модуле без графической связи с событиями интерфейсных элементов.

В 1С языках процедуры обработчиков событий иногда называются - предопределенные процедуры.

Автор:  SergeyNK [ Вторник, 15 Январь, 2013 23:21 ]
Заголовок сообщения:  Re: Тестирование ИС Дракон

Геннадий Тышов писал(а):
SergeyNK,
У Вас в модуле много схем, разместите их на нескольких листах,


Ок! Я предполагал об этом. Хорошо, что есть возможность сборки с нескольких листов. Воспользуюсь.

Автор:  onway [ Пятница, 08 Февраль, 2013 10:14 ]
Заголовок сообщения:  Re: Тестирование ИС Дракон

Пожелание:
предусмотреть режим формирования модуля, в котором оператор GOTO используется только для множественных веточных переходов.

Если
добавить в ИС Дракон точки выхода для возможности вписывания операторов
Для циклов: КонецЦикла,Прервать, Продолжить.
Для Условий: КонецЕсли, ИначеЕсли, Иначе.
Для Процедур: Возврат.
Тогда
программу можно будет действительно использовать для генерации кода "1С предприятие".
Иначе
данная среда годится только для укрупненного и приблизительного графического представления.
КонецЕсли;

Автор:  Владислав Жаринов [ Пятница, 08 Февраль, 2013 10:41 ]
Заголовок сообщения:  Re: Тестирование ИС Дракон

Это как здесь, что ли?..

Автор:  onway [ Пятница, 08 Февраль, 2013 12:53 ]
Заголовок сообщения:  Re: Тестирование ИС Дракон

На тему эргономичности отображения имеем 3 варианта:
1. Дракон-схема
Изображение
2. Код на ИС Дракон
Код:

    // G:\Dragon_2013_02_01\Новый_02.drt
    // 1. Схема - процедура, Изменение 08.02.2013 13:14:01, Начало
Функция КоличествоЭлементовВыборки(Выборка)


    // ==================== Шампур

    // 2. Заголовок / Количество элементов
    // -7. Параметры / Выборка

    // 4. Действие / количество элементов = 0
    // -13. Правый комментарий / Возвращаемое значение
КоличествоЭлементов = 0;

~М3:
    // 3. Цикл Вопрос / Получили следующий элемент == Да
Если Выборка.Следующий() Тогда Перейти М6;

    // 5. Конец / Конец
Перейти М_end1;

    // ==================== Шампур

~М6:
    // 6. Действие / Увеличим количество элементов на единицу
КоличествоЭлементов = КоличествоЭлементов + 1;
Перейти М3;

    // 1. Схема, Конец
~М_end1:
Возврат КоличествоЭлементов;
КонецФункции



3. Код на "1С Предприятие"
Код:
Функция КоличествоЭлементовВыборки(Выборка)
   
   КоличествоЭлементов = 0;
   
   Пока Выборка.Следующий() Цикл
      
   КоличествоЭлементов = КоличествоЭлементов + 1;   
   
   КонецЦикла;
   
   Возврат КоличествоЭлементов;
   
КонецФункции


На мой взгляд код сгенерированый в ИС Дракон назвать "эргономичным" можно только в кавычках. Обслуживание такого кода только увеличит трудозатраты и пользоваться такой генерацией не представляется возможным.

Вывод: ИС Дракон хороша только в рамках стратегической/укрупненной карты решения задачи.

Вложения:
SNAG-0522.png
SNAG-0522.png [ 15.52 КБ | Просмотров: 20457 ]

Страница 13 из 14 Часовой пояс: UTC + 3 часа
Powered by phpBB® Forum Software © phpBB Group
https://www.phpbb.com/